Jump to content


Pt Colborne Marine SUCKS!


Recommended Posts

Got my boat back after 6 weeks, and my son

and I took it out to try tonight...still the same problem as when I took it in!!

it idles fine, but as soon as you give it any gas it sputters and dies!

Pt C mechanics are terrible!

 

Link to post
Share on other sites
9 hours ago, Lund-SS said:

What year ? What engine ? And have you ever changed your fuel lines?

Mechanic told me that some of the older hoses brake down with the ethanol fuels now.

As you say it's something about the black or Gray hoses.

I'd try some Sea foam in your gas, could help. 

Edited by Fish Farmer
Link to post
Share on other sites
On 7/23/2020 at 8:16 AM, kevin said:

See Mike Lyrette at Lyrette Marine on Courtwright St in Fort Erie.  They'll fix you up.  

I second Mike Lynette. He does great work and is prompt. I had a problem with my Optimax and his mechanic fixed the problem on the spot. Was a bad electrical connector inside the motor. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...